This project is read-only.

Not able to run the Scrum Sprint Monitor

Sep 15, 2010 at 12:01 PM

Hello,

I have tried to setup SSM for some time now, but I've given up every time I try. So, I figured I'll try to get some help here.

First of all I have ran the Config application, and setup everything except team members. I've tried "Generate file from current sprint", but it crashes the config app. So, that's the first problem.

Second when I try to run the screensaver, it loads for about a minute, then shows an error saying something like "Cannot connect to remote server". When I take a look at the log file it looks as if it's trying to connect to this address: 65.55.11.215:443 (which isn't where I have my TFS:)).

Here's part of the log:

2010-09-15 12:48:41,648 [1] INFO  ScrumSprintMonitor.Implementation.Sprint [(null)] - Exception assigned to ISprint.Exception.
System.Net.WebException: Kan ikke koble til den eksterne serveren ---> System.Net.Sockets.SocketException: Et tilkoblingsforsøk mislyktes fordi den tilkoblede parten ikke svarte på riktig måte etter en tidsperiode, eller den etablerte tilkoblingen mislyktes fordi den tilkoblede verten ikke svarte 65.55.11.215:443
   ved System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   ved System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
   --- Slutten på sporingen av intern unntaksstakk ---

Oopps.. it's in Norwegian.. What it basically says is that it cannot connect to the remote host, and I have no idea where 65.55.11.215 comes from... hard coded in the screensaver???

My config looks like this:

<?xml version="1.0"?>
<configuration>
  <configSections></configSections>
  <appSettings>
    <add key="TfsServerName" value="MyTFS" />
    <add key="TfsServerUri" value="http://machine.subdomain.domain.no:8080/tfs" />
    <add key="TfsServerUserName" value="user" />
    <add key="TfsServerPassword" value="password" />
    <add key="ConfigurationFilePath" value=".\Config\SprintConfiguration.txt" />
    <add key="PresentationConfigurationFilePath" value=".\Config\PresentationConfiguration.txt" />
    <add key="TeamMembersConfigurationFilePath" value=".\Config\team-info.xml" />
    <add key="WakeUpMachine" value="False" />
    <add key="TimeOfDayToWakeUpMachine" value="08:00:00" />
    <add key="SuspendMachine" value="False" />
    <add key="TimeOfDayToSuspendMachine" value="18:30:00" />
    <add key="EnableOutlookIntegration" value="False" />
    <add key="ConsiderOutlookTentativeAsFreeTime" value="False" />
    <add key="ReportUnestimatedSprintBacklogItems" value="False" />
    <add key="ActiveSprintMode" value="Sprinting" />
    <add key="ShowBurndownChart" value="True" />
    <add key="UseMultipleMonitors" value="False" />
    <add key="OptInCEIP" value="False" />
    <add key="ClientSettingsProvider.ServiceUri" value="" />
  </appSettings>
  <system.web>
    <membership defaultProvider="ClientAuthenticationMembershipProvider">
      <providers>
        <add name="ClientAuthenticationMembershipProvider" type="System.Web.ClientServices.Providers.ClientFormsAuthenticationMembershipProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" />
      </providers>
    </membership>
    <roleManager defaultProvider="ClientRoleProvider" enabled="true">
      <providers>
        <add name="ClientRoleProvider" type="System.Web.ClientServices.Providers.ClientRoleProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" cacheTimeout="86400" />
      </providers>
    </roleManager>
  </system.web>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
  </startup>
</configuration>

I hope someone can help me out with this, as I'm not spending more time on this now... Thanks!

Sep 15, 2010 at 11:49 PM

Hi,

 

Your config file looks fine. Regarding that IP address, that is not hardcoded anywere in the SSM. My guess is that it is getting it from your Windows Registry. Can you do a search for it using Regedit.exe and see what you come up with?

By the way, just to double check, do you have Team Explorer 2010 installed, and have you already set up the connection to your TFS server in it?

Thanks,

Pedro

Sep 16, 2010 at 8:42 AM

Hello Pedro,

Thanks for your quick answer.

First of all, I got it working by downloading and building the source. I think the problem was that we are using Scrum For Team System v3, and that's not included in the downloadable .exe? Anyways, even though it's working it shows a bit strange numbers. E.g. it shows that we have 15 open Backlog Items, even though we only have 13 open.

I'm going to investigate a little bit, as there's also some other "strange" things showing... I'll report back.

Jan-Erik